阿西河

所有教程

公众号
🌙
阿西河前端的公众号

我的收藏

    最近访问  (文章)

      教程列表

      抓包专区
      测试专区

      npm 更新已安装的包

      更新本地安装包

      定期更新你的应用所依赖的包(package)是个好习惯。

      因为依赖包的开发者更新了代码,你的应用也就能够获得提升。

      为了完成这个任务需要:

      • package.json 文件所在的目录中执行 npm update 命令。
      • 执行 npm outdated 命令。不应该有任何输出。

      更新全局软件包

      要更新全局软件包,请键入:

      npm update -g <package>
      

      例如,要更新名为jshint的软件包,请输入:

      npm update -g jshint
      

      找出需要更新的软件包

      要找出需要更新的软件包,请键入:

      npm outdated -g --depth=0
      

      https://a.axihe.com/edu/npm/npm-update-01.png

      要更新所有全局软件包,请键入:

      npm update -g
      

      低版本npm

      如果您使用的是2.6.0或更低版本对于小于2.6.1的npm版本,运行此脚本以更新所有过时的全局软件包。

      但是,请考虑升级到最新版本的npm。

      为此,请键入:

      npm install npm@latest -g
      
      目录
      目录